BC 4x4 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 1993 ford ranger V6 3.0L 2wd 5spd.
the other day I went to start it and all the happened was the celenoid clicked. no starter, no buzzing...nothing but a strong "Click" each time I turned over the key. I replaced the celenoid....then I checked the starter...no gears stripped or bad electrical connections. what's wrong with my truck? is it electrical? or mechanical?

help!
 

·
Registered
Joined
·
14 Posts
did you check th battery most comin problem


------------------
1983 BRONCO 3" BODY LIFT 33 12.50 351 WITH EDELBROCK PERFORMER
 

·
Registered
Joined
·
898 Posts
The ******* test: Short across the battery and starter terminals of the solenoid. If it cranks and starts, the solenoid is hooped. If it just gives a loud "click", the starter is probably shorting out. Been there, done that, got real good at pulling starters.....

------------------
Blue coyote
"Broncenstein" is:
chopped 84 BII
(early model Navigator)
6" lift, 32's
4.10's w. rear l/s
 

·
Premium Member
Joined
·
1,541 Posts
So it sounds like u got the same problem i had on my bronco II (that loud clicking sound when u turn the key).I just fixed mine yesterday . I replaced my selonoid and then it still only worked %50 of the time then i cleaned my batery terminals with sand paper and it starts %100 of the time. So i suggest check all your batterie wires including your grounds and if that dont work replace the seloniod. Let me know how u made out

 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
I cleaned up the battery good and checked and replaced all leads including the ground. It worked! I would never have guessed. It's always easier than you think. thanks so much!
 

·
Premium Member
Joined
·
1,541 Posts
no problem ! love to help a fellow ford owner
 
1 - 6 of 6 Posts
Top