BC 4x4 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hey guys and gals, i went out to the ol' mud pit behind home depot last night with my f150, and to my surprise i heard a horrible crrrackkk come out of my front end, it was while i was in 4hi and i was turning left both times it happened, i'm new to this sport and its my first truck so i am wondering if i should be worried or if its something i should get used to hearing...thanks alot Blair


------------------
Blair
'96 V8 F150 4x4 5sp Stock so far....
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #2 ·
haha wow the monkey really showed up big! oops! lol


------------------
Blair
'96 V8 F150 4x4 5sp Stock so far....
 

·
Registered
Joined
·
2,962 Posts
Sounds like a hub. Or perhaps a u-joint has blown. You should check it out cause nothing should go crack.

Wes


------------------
...a member of the herd
www.hot.alloffroad.com
 

·
Premium Member
Joined
·
845 Posts
Sounds like a hub to me as well... Time to crawl under the front end and check stuff out. What year 150? Auto or manual hubs?

------------------
Steve Dillen
'90 Ranger. . .pretty much MIA -- stolen on 9/22.
'94 S10 Blazer. . .pretty much a soccermobile.
 

·
Registered
Joined
·
20 Posts
Originally posted by vpsbiker:
Hey guys and gals, i went out to the ol' mud pit behind home depot last night with my f150, and to my surprise i heard a horrible crrrackkk come out of my front end, it was while i was in 4hi and i was turning left both times it happened, i'm new to this sport and its my first truck so i am wondering if i should be worried or if its something i should get used to hearing...thanks alot Blair


Hey I have a 81 Ford F150 4x4 and it has warn hubs. I too had the same noise on my truck when the hubs were locked and whether or not engaged in 4x. It would only happen when the wheels were turned. I went under and greased all the nipples and the noise went away. Grease the u-joint nipples as well.



------------------
Azorian Dan
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
well apparently i have blown ball joints on that side, maybe thats the problem,i'm getting them fixed right away and i do have the auto lock hubs, thanks for your help guys, blair

------------------
Blair
'96 V8 F150 4x4 5sp Stock so far....
 
1 - 6 of 6 Posts
Top