BC 4x4 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
Okay...I have an 80 Yota with a 20r. Drove to work fine this morning but on the way home it started idling real rough and about 250 rpms below where it was set. Pulling off a plug wire doesn't seem to make a difference, and adjusting my idle screws etc... doesn't change anything... Any ideas? It also backfires periodically when i downshift.
 

·
Registered
Joined
·
7 Posts
Could be AAP diaphragm is leaking. It's on the R side of carb, under a cover held on with three small screws. I have to replace this every few years on my '79 w/20R. If the vacuum hose attached to it is gassy, it's surely leaking and excess fuel is sucked into the intake manifold.

The solenoid shut-off valve, screwed into the back of the carb, R side, also quit on mine, causing super rich running, backfiring, etc. Disconnect its wire. Apply/release/apply/release 12V. It should click. If it does, also unscrew it and check the condition of the tiny o-ring on its tip. Mine was dead but I found a clicking one at a junkyard and it's been fine for years now.

Good luck, let us know how it goes.
 

·
Moderator
Joined
·
1,269 Posts
If there lots of milky white smoke coming out the tailpipe.. perhaps your head gasket?

------------------
'86 Toyscrota, currently in too many parts to count.
"Pushing the limits of duct tape and zap straps every day."
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #4 ·
Thanks I'll check that out.
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #5 ·
Nope, no white smoke, i am gonna check the fuel filter too, i ran some methyl hydrate through my fuel system a week or so ago, and someone told me to check the fuel filter
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #6 ·
Okay...I am pretty certain it's the AAP diaphragm. Took off the cover plate and gas started pissing out through the diaphragm. So i will change that and go from there. Thanks a lot guys.
 
1 - 6 of 6 Posts
Top