BC 4x4 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter · #1 ·
Alright fellas well its an 81 with an 83 22r engine(180,000kms)-4 speed.I bought this truck 3-4 weeks ago.
I have 2 different oil leaks going on right now,
#1:
at the very front of my valve cover were the the half moon peice of rubber is oil is coming out of there slowly or sometimes more(like maybe 150ml at most,not even) will come out when its being reved hard.It looks like there isnt a good seal between the vlave cover and the engine-there is a space in the seal.Also the half moon peice of rubber dosent seem to be seating properly.There is the blue sealant goo all the way along the cover.You can see were oil is barely coming out along the sides of the cover all the way to the firewall if you run it hard and long-it.None of my guages are currently hooked up(last owner dident see a need I guess) and Iam in the process of sorting them out but there different wiring harnesses etc.It dosent seem to be over-heating at all(although no gauge to tell me)and I have run it for a long period of time on numerous occasions-it has a new rad and I have just done a rad flush.It does get hot but I would be very suprised if the head was fruckered.
Any ideas on why this is happening??
#2:
Coming out were the tranny meets engine seal.I have tightend down all the bolts but oil is still leaking out of there-not too much but enough to wonder why-it does drip down a bit.Iam thinking a bad tranny seal?If thats it will I have to pull the tranny and replace the seal:( ?
Any help or suggestions would be great,
Thanks Brett
 

·
Registered
Joined
·
145 Posts
If you have engine oil coming out between your engine and transmission your rear main seal is toast. You have to pull the trans to replace it.
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #3 ·
Thats what I figutred but I was praying not.Seal kit price on this?
Anyone else?
Thanks Brett
 

·
Registered
Joined
·
363 Posts
#1
you pretty much answered yourself. the valve cover seal. clean off all the silicone and put a new one in. the're like $15

#2
most likely the rear main seal or gasket. but also possibly the oil pan gasket or the tranny input seal. again, like $15. the rear main requires pulling the tranny, flywheel and oil pan. therefore another $10 for a pan gasket. see if what is dripping appears to be engine or gear oil.
 

·
Registered
Joined
·
389 Posts
well looks like the rear main seal,best bet take it out and replace it. your valve cover moon shape seals should be replaced with new ones,you can get ehm from toyota,or go get a toming chian kit most of all your top end seals come with the kit ,and replave your timing chain ,
and when intallln also use a bit of silacone on the moom shape sealsmnd for the rea main seal use gear oil or grease and lube up the seal befopre installing it,i like grease works better,and make sure you dont fold the seal.
but its sounds like yo have a bit of a job on your hands like a few hours worth of work like 4 or so ,possibly less
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #6 ·
Cool thanks fellas-I thought I knew what the problems were but I wanted to know for sure.I guess I'll be doing this on the weekend.
Thanks Brett
 
1 - 6 of 6 Posts
Top