BC 4x4 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
237 Posts
Discussion Starter · #1 ·
My horn stopped working today
When i push on it, there is a click noise, kinda like a spark. Is there a fuse, On my fuse panel I dont see a label for horn
This is on an 81 Cj5.

------------------
Blue 1981 CJ5 33X12.5 tires
*Damnit, anyone see where that door went?"
 

·
Registered
Joined
·
443 Posts
There should be a fuse, look in the manual it will have a diagram of what all the fuses are for, or just start pulling fuses to see which one has crapped out, or it could be the contacts are dirty, or did you just install a stereo? Check all wires.

------------------
81 rust bucket Bronco 33" muds just for havin fun
 

·
Registered
Joined
·
237 Posts
Discussion Starter · #3 ·
Think I found the problem, theres a brown cube between the horn and the steering wheel, i think its a relay, whatever it is wont function without it

------------------
Blue 1981 CJ5 33X12.5 tires
*Damnit, anyone see where that door went?"
 

·
Registered
Joined
·
443 Posts
take a multi-meter and test voltage into brown box and voltage out that'll tell you if that is your problem if there is no voltage in when you press the horn, then it is not that that's causing your problem. It's probably some sort of fusible link.

------------------
81 rust bucket Bronco 33" muds just for havin fun
 

·
Registered
Joined
·
114 Posts
there is a relay going to the horn. mine went, and i went to crappy tire,and for like 10 bucks it works again

------------------
1985 cj7 6inch lift,6 point cage,custom $25 paint job with flames,engine done up,32inch mud tires,cb,alarm.(future mods, lockers,dana 60 rear,dana 44 front,soft-top,leaf over,mabey 40inch boggers and a amc 360 for power)also a member of bone shakers 4x4 club.
 
1 - 5 of 5 Posts
Top