BC 4x4 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I am getting a knocking sound coming from beneath my feet when it gets bumpy. Has anyone had this problem? I removed my sway bar for more flex, could this let something go loose? Could it be my front driver side shock? Any info is appreciated.
 

·
Registered
Joined
·
107 Posts
take a look at your exhust system mount maybe the one near your foot has come loose
cant see it comeing from the sway bar ?
Also try looking at your t-case mounts (Now iam just gessin )

------------------
92 zuk 32x11.50 BFG
5:13s rocklights....
 

·
Registered
Joined
·
9 Posts
I had the same symptoms... my problem was I had ripped my transfer case mounts.
Might be something to check out.
 

·
Registered
Joined
·
134 Posts
I'd agree with schmiot, mine does the same thing, and I just went through and gave mine a VERY thourough inspection. I know that my bushings are on their way out so that's what I figure is causing my noise.

$.02

------------------
Farewell and Adieu, to you fair Spanish ladies...
 

·
Registered
Joined
·
43 Posts
I had the same thing on somewhat new Black Diamond Shocks. I ended up by accident really, driving it a few meters without the front shocks and voila no more sound!

Had the front right replaced under warranty and that fixed it. Worth a look if your stumped.

Paul.

------------------
The SuperFly will return once again...
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #7 ·
I hope its something simple like my leafs, I dont want it to be major surgery. Thanx for the info.
 
1 - 7 of 7 Posts
Top