BC 4x4 Forums banner
1 - 11 of 11 Posts
G

·
Discussion Starter · #1 ·
I drive an 88YJ with the 4.2L six. I'm having a problem with oil coming out of the rear breather hose in the valve cover into the air cleaner chamber. If I wasn't running a K&N it would cost me a fortune in paper filters. Any advice?


------------------
High Country Explorers
Red YJ 4" lift
"I hope that was the skidplate"
www.members.home.net/ichris4x4/index
 

·
Registered
Joined
·
102 Posts
Funny you say that I just cleaned my K&N last nite and noticed some oil in my air filter housing as well. I also noticed that a fiberous type filter about and inch and a half by maybe an inch that is attached inside the air filter housing near the back of it was saturated in oil.

Whats causing this ?

thanks also

Jason

------------------
1990 YJ. Lots O'Fun
[email protected]
 

·
Registered
Joined
·
128 Posts
IBJeepin: Ditto!
I JUST cleaned out my filter, and at the bottom there is a sick oil coated grunge in it.
All I did was clean it out and I havent seen any new stuff yet...

------------------
1987 3" lifted YJ with 31" KOs new paint etc.
 

·
Registered
Joined
·
160 Posts
It is usually caused by blow by in the cylinders or can be caused by excess crankcase pressure.

------------------
90 Sub,496BBC,d60,14b,detroits f+r, 44 boggers,th400,np205,insane ,warn15000,balls of steel
 

·
Registered
Joined
·
102 Posts
Dirty PCV valve.

ie: excess crankcase pressure like camoburpin said.


------------------
Phil M. - Kent, WA
95 XJ Sport w/Stuff
"Who cares about a list of crap, can you drive it?"
 

·
Registered
Joined
·
1,546 Posts
Yep, clogged breathers on the valve cover. Replace the breather grommets and the plastic vacuume lines attached to them.



------------------
Chris S.
2002 KJ - staying stock (almost)
2000 TJ - 2" suspension lift, 1/2" body lift, assorted skids, hooks, rock rails, rock lights, 33" BFG MTs, custom bumper, Warn 8274
Mud Puppy's Jeep site
 

·
Registered
Joined
·
23 Posts
I have this problem too, I have to change the airfilter every time I change my oil. I thought it was a ccv problem but apparently not. I took it in for a compression/leakdown test and the mechanic told me that one of my piston rings was worn, and I needed a new engine. Being poor as hell, I haven't rebuilt or bought a new engine, I've just been driving it, for almost a year now like this.

Just something to check anyhow, hopefully this isn't your problem though!

------------------
1991 2.5L 4cyl
30" BFG AT
 

·
Registered
Joined
·
418 Posts
common problem for YJ's and XJ's alike.sometimes changing the rear grommet is not enough,the baffle inside the valve cover can be clogged and needs to be removed and cleaned.there is an exellent tech article on this at [email protected]
 

·
Registered
Joined
·
1,546 Posts
Originally posted by ScottH:
....baffle inside the valve cover can be clogged and needs to be removed and cleaned.there is an exellent tech article on this at [email protected]
You mean this one? http://www.off-road.com/jeep/cherokee/98/04_apr/valvecover/cover.html





------------------
Chris S.
2002 KJ - staying stock (almost)
2000 TJ - 2" suspension lift, 1/2" body lift, assorted skids, hooks, rock rails, rock lights, 33" BFG MTs, custom bumper, Warn 8274
Mud Puppy's Jeep site
 

·
Registered
Joined
·
1,546 Posts
Originally posted by ScottH:
yes,it didn't totally solve my problem,but reduced it by 75%
Glad it helped.


The Comanche in the article eventually needed a rebuild, but the cleaning gave it another year's life first.



------------------
Chris S.
2002 KJ - staying stock (almost)
2000 TJ - 2" suspension lift, 1/2" body lift, assorted skids, hooks, rock rails, rock lights, 33" BFG MTs, custom bumper, Warn 8274
Mud Puppy's Jeep site
 
1 - 11 of 11 Posts
Top