BC 4x4 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
419 Posts
Discussion Starter · #1 ·
Ok, so I've ruled out the tire imabalance for the vibe. I'm now thinking it might be the U-joint between the tranny and the driveshaft. I got under there a while ago and gave the shaft a good shake (hmmmm.... that sounds bad) and it seemed pretty solid, but it could be that my tires were on the ground and there would BE no play in it because the axle wouldn't move... SO... I'm going to go check the UJ between teh tranny and the shaft... could that be a possibly vibration?

------------------
'89 4.0L Cherokee Laredo
 

·
Registered
Joined
·
419 Posts
Discussion Starter · #2 ·
OH I FORGOT TO MENTION....
the U-joints are greasable.. I know this might be a long shot, but if I greased them up could that possibly get rid of my vibe?

------------------
'89 4.0L Cherokee Laredo
 

·
Registered
Joined
·
397 Posts
if I greased them up could that possibly get rid of my vibe?
Very unlikely


If your tires are balanced, then u-joints are the next most likely suspect. Best way to check them is to remove the shaft, which really isn't a big job on a YJ. Watch out that the caps on the lower joint don't fall off when you've removed the retaining straps!

Once it's off, you'll be able to move each joint by itself, and check for play by twisting each one.

Good luck,
Chris

------------------
See my Jeep's website:
www.bc4x4.com/chrisw
 

·
Registered
Joined
·
419 Posts
Discussion Starter · #4 ·
yeah we figured out that the U-joint on the pinion was a little cockeyed, but I need a new UJ anyway.



------------------
'89 4.0L Cherokee Laredo
'No woman.. don't use my shifter an oh shit handle!!!'
 

·
Registered
Joined
·
419 Posts
Discussion Starter · #6 ·
235/75/15

------------------
'89 4.0L Cherokee Laredo
'No woman.. don't use my shifter an oh shit handle!!!'
 

·
Registered
Joined
·
419 Posts
Discussion Starter · #7 ·
Its the yoke, it seems to be missing a tab on the pinion yoke to hold the U-join in place. So the U-joint is slopping out to one side. Anyone know how much these things usually run for for an '89 4.0L Cherokee on with a '94 rear end?

------------------
'89 4.0L Cherokee Laredo
'No woman.. don't use my shifter an oh shit handle!!!'
 

·
Registered
Joined
·
419 Posts
Discussion Starter · #9 ·
Yeah we figured out that it wasn't the U-joint but the yoke. One of the centering ridges on the yoke was either ground off or broke off. So I'll be getting a new one from Craig this week.



------------------
'89 4.0L Cherokee Laredo
'No woman.. don't use my shifter an oh shit handle!!!'
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top