BC 4x4 Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
431 Posts
Discussion Starter · #1 ·
As the topic says...

anyone one this board done one of these?

what's involved?

any websites you can point me to? (i searched and found none)

I figure the harness should be pretty simple and I can drop an FI sami's pump into my carb'd sammi's tank to make the FI conversion easier... sound right?

Thanks

David
 

·
Registered
Joined
·
79 Posts
David,

I assume you are talking about the twin cam 1300.

If you are using a port fuel injected motor, it will most likely require higher pump pressure than your throttle body fuel injection(samurai), and the computer will be different for sure- read you will have some wiring to do. If you are patient, you could sit down with both wiring diagrams and figure it out. Also be aware that something must be done with the dist on the 1300 twin cam- you may need to clearance the firewall.

I have never done this conversion myself, but I have seen it installed.

If I had a 91 Samurai (hmmmmmm) I would put the 1600 8v with the whole 'kick intake/exhaust and enjoy the 95lb/ft of torque. This will allow you to retain the sammi pump.

:cool:
 

·
Registered
Joined
·
431 Posts
Discussion Starter · #3 ·
hehehe...

I wish I had a 91... just an '88 but I thought an in tank pump might be a better idea for FI than an external inline one.

Didn't know about having to make firewall clearance for the dist. that might squash the whole idea :angry

David
 

·
Registered
Joined
·
1,609 Posts
Another problem to consider with the Twin-cam swap...finding the damn thing. They are becoming more and more rare, it's gonna be really hard to find one.

A 1.6L swap might be easier. You need a new pump, computer, and stuff like that though...not cheap. Unless your going extreme, the 1.3 can handle a lot with the right gears.
 

·
Registered
Joined
·
51 Posts
dont even bother with the twincam, it s a bit if work and isnt all its made up to be anyways, it has no low end torque, and there is very few parts.
i just sold my toyota carolla hemi engine and he is going to put it in his sami, they have loads of torque and are a much easyer fit
 

·
Registered
Joined
·
431 Posts
Discussion Starter · #6 ·
big blue said:
dont even bother with the twincam, it s a bit if work and isnt all its made up to be anyways, it has no low end torque, and there is very few parts.
i just sold my toyota carolla hemi engine and he is going to put it in his sami, they have loads of torque and are a much easyer fit
I do have a line on one.... and they gotta be better than the stock engine right? Besides... torque is just cam and gears.

I was more interested in how difficult a swap it is. I'm looking for the easiest, cheapest FI swap (there is no way in hell I'd carb a 1.6). Seems everyone wants literally an arm and a leg for the 1.6... a good one (with harness) and they're asking like $1500 bucks and up.

David
 

·
Registered
Joined
·
51 Posts
i know somebody who did it and he was under the hood every time we went out 4x4ing, if it wasent the fuel pump it was the mass air flow sensor

you need everything of the car you can put all the cam and gears you want in it but when you gain one thing you loose something else! they are getting very scarse for parts
the toyota 1.8 hemi has way more power
 

·
Registered
Joined
·
3 Posts
David,

I did a 1.6 16 valve out of a four door sidekick, wired it with no problems, my fuel pump is an external. it works great but the pump is a bit noisey being external. i have no lack of power with 33's and stock gearing. great engine
 

·
webwheeling...
Joined
·
1,475 Posts
twin cam

David,
Hear me now, DO NOT PUT CAM(s) IN A TWIN CAM. You will just be wasting your money since they don't do anything in a twin cam except screw up your top end HP. A twin cam is an upgrade over a carb'd 1300 in that it's injected. Without gearing coming out your ying, yang it pretty much sucks for wheeling. For more HP and torque go with a 1600.

Geez big blue,
You talk like you were out wheeling everyday with that guy that kept wasting fuel pumps...

Maybe if you spent less time jabbering on the net and more time fixing your TOYOTA, then you'd be able to bring MY WELDER BACK!

:angry

:welder
 

·
Registered
Joined
·
431 Posts
Discussion Starter · #10 ·
Re: twin cam

Shogunator said:
David,
Hear me now, DO NOT PUT CAM(s) IN A TWIN CAM. You will just be wasting your money since they don't do anything in a twin cam except screw up your top end HP. A twin cam is an upgrade over a carb'd 1300 in that it's injected. Without gearing coming out your ying, yang it pretty much sucks for wheeling. For more HP and torque go with a 1600.
Blech...

Not exactly what i wanted to hear... but it's better to hear from someone else making a mistake than me going out and repeating that mistake.

I guess the quest for a wrecked tracker continues.

David
 

·
webwheeling...
Joined
·
1,475 Posts
good move

I don't think you will regret it. Not that I didn't enjoy my twin cam experience but I was glad to see it leave my garage (out of my truck) to become the burden of someone else. I got tired of the torqueless wonder. Now we're on to bigger and better things. Got six? V6 that is... :*******
 

·
Registered
Joined
·
261 Posts
I agree with dave , the twin cam is a pile of junk . The wirring harnes in mine is really fuct (aint running).
Im goin 6 soon also just need to find the best combo and cheapest way to do it.Just want to get the damn motor running before I pull it so i can lay the BURDEN on someone else.
(Thanks for selling me the burden motor dave :D , got that suzuki manuel? :soso )
 

·
Registered
Joined
·
51 Posts
dont worry david ill get the welder back to you this week, the toy is on the road now, and i still have some shares in the welder
its not al yours, though i dont use it much that little bit helps me get by. ttl
 

·
Registered
Joined
·
296 Posts
So. this 1.8 toyota corolla hemi engine someone mentioned: They came in Corolla's only? What years? You have to use the toyota tranny with it? Will that tranny mate to a Zuki T-case if so how? The clutch how would that get 'set up'? are there parts availability for them? Just planning down the road, only answer if you have time or feel like it thanks.
 

·
webwheeling...
Joined
·
1,475 Posts
Kev

Not that I really want to know ('cause it usually means I've got work to do) but what is it doing? Is running at all or just idles and dies if you give it gas? That harness should be fine 'cause everything is there but it could be a sensor.
I've got the manual (just found it). I can copy it for you (I don't remember how much it costs to have it copied and bound at staples) or you can copy it yourself (as long as I get it back...)


Brett,
I bought you out, making it my welder. Remember some 33's and rims, some stock tires and rims and some other stuff along the way? You :confused: :*******. Besides I need it today! You know you are allowed to use it. But timeliness for its return is appreciated.
 

·
Registered
Joined
·
261 Posts
Ya , that would be cool to get it copied at staples , ill go there and ask them how much $$ . As for the problem , It dosnt start period, but it turns over , all electrical works. i found a fuse that keeps blowing out in the fuse box (its the big pink one 30A) and ive tryed to trace it but i cant find what the use is for it? dont know if thats the problem or not? The fuel pump seems to be fine when i turn it over it has fuel pressure. Im just fawkin stumped. Would like to get it done this week to ramp it at the sport trucks event cause i tubbed it and have the bump stops all fabbed up, so ill do much better than last year. Was contemplating taking it to rio to see if he could figure it out but i dont have much extra time right now.
Any help would be great . Thanks dave.
 

·
Registered
Joined
·
51 Posts
i am trying to retern it as soon as i get my charging system working.
and i paid you out for the 33s, just not the stock ones and you wanted 200, i have more than 200 into the welder
it cost almost 800, steve put in 100 and the rest you and i put in
but i realy dont care cause i rarley need it and do apriciate the time you have given it to me, as soon as i get my alt working so i dont die half way there i will run it out
:beer
 

·
webwheeling...
Joined
·
1,475 Posts
Brett,
I'm just giving you a hard time.
Thanks for bringing it back.

Kev,
I won't have time to do anything before next week. So if you want the manual you'll have to get it from me tonight 'cause I'm going camping this weekend (call me 536-5991). I don't need it back immediately so you can use and or copy it at your leisure (well maybe for a couple weeks or something). Reo is a good source on those, that is for sure but he doesn't like the electrical end of things. IF a fuse keeps blowing I'd be inclined to suggest something has changed in that harness. Either something isn't grounded properly or maybe you've changed some other part of the electrical and it's causing it to run too much juice through that fuse. I would check your ground for the starter and alternator first, then all of the other smaller guage ones. I assume it is when the starter is cranked that it happens if you can activate the fuel pump. If that doesn't turn anything up then have a look in the manual and trace the wire. I know the wire you are talking about but can't remember where it goes either (it's been a long time).
Any ways call me and good luck
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top